21 agosto 2012

Instalação e configuração do emulador Android SDK (com plugin ADT do Eclipse)


Neste post abordarei sobre a instalação do Android SDK e a instalação do plugin ADT para desenvolver com a IDE Eclipse, bem como algumas dicas para atualizações automáticas dos seus componentes.



Pré-requisitos para instalação e configuração dos ambientes:
1) Eclipse IDE (versão + recente) - usei a JUNE 4.2 de 32 bits;
2) Android SDK (versão + recente);
3) JDK 1.6 ou superior;
4) JRE (no path do SO)
5) Página com instruções para instalação do Plugin ADT

Configurações mínimas do hardware e software do sistema operacional

(1) Requisitos de sistema (fonte)


Inicialmente você deve baixar todos os programas indicados acima. Pode ser que você já tenha o interpretador Java (JRE), entretanto, vai precisar o JDK para programar para Android. Veja a figura (1) destacando que não basta a JRE.

Siga as dicas do vídeo ou então siga os passos seguintes:


  • Baixe o Eclipse IDE [pré-requisito é o item (1)];
  • Baixe e instale o Android (no caso do Mac OS é apenas um zip);
  • Rode o Eclipse e instale o plugin ADT (URL download abaixo):
https://dl-ssl.google.com/android/eclipse/
  • Baixe os pacotes do emulador Android (siga essas dicas);
  • Configure o Eclipse para fazer checagem automáticas de atualizações do plugin (veja o vídeo acima)
  • Crie um atalho para um emulador AVD (Android Virtual Device) (dicas aqui);
  • Rode o programa usando o Eclipse


Série: Android Dicas (no youtube)
Este vídeo faz parte de uma série que estou fazendo sobre dicas Android (no YouTube). O link da série está aqui. http://www.youtube.com/playlist?list=PL5EFD4E0D0D24F43E

6 comentários:

amanda disse...

Eu gostaria de saber, se a criação de aplicativos para Android em diferentes versões deste S.O, é diferencial?
Por exemplo, criando um aplicativo na versão 4.1 usaria uma codificação diferente para a versão 2.3? ou seria a mesma? (claro que para isto, eu teria que baixar o pacote para a versão desejada)
Só para constar tô começando agora e não sei nada XD!

Douglas Del Frari disse...

Oi Amanda,

Ao criar uma nova aplicação Android você deve informar obrigatoriamente duas informações no arquivo de configuração AndroidManifest.xml:


uses-sdk
android:minSdkVersion="8"
android:targetSdkVersion="15"


Sendo que uma representa a configuração mínima do SO para versões antigas. Ou seja, até qual versão antiga do SO Android o seu aplicativo atual vai ser suportado. O "target" é o SO atual.

Portanto, um aplicativo que fosse 4.1 poderia sim funcionar para versão 2.3 desde que atenda a configuração mínima. Obs. O android trata essa nomenclatura por API nível. Sendo que o nível 9 é o Android 2.3 (GingerBread).

FLABIANA disse...

OLÁ, Estou usando o Eclipse e o emulador abriu mas não mostra o projeto na tela, será que meu computador e muito lento para isso?
Ele tem 2gb de memoria processador celeron t3100, windows 7,Grata.

FLABIANA disse...

OLÁ, Estou usando o Eclipse e o emulador abriu mas não mostra o projeto na tela, será que meu computador e muito lento para isso?
Ele tem 2gb de memoria processador celeron t3100, windows 7,Grata.

Douglas Del Frari disse...

Olá Fabiana. Realmente o emulador Android é pesado. Existe uma alternativa chamada Genymotion que pode ser usado. Eu já testei e achei bem melhor. No entanto, se vc tiver um celular Android, ai vc não terá esse problema. Rode direto no celular que seus problemas de performance serão simplificados.

Anônimo disse...

Eu sou iniciante neste assunto,eu queria saber por onde eu começo a estudar sobre esse assunto, me dê algumas dicas por favor, sou muito interessado em linguagem de programação.